Anchor US Issue
Incident Report for Axcient
Resolved
This issue has been resolved. Thank you for your patience.
Posted Aug 03, 2018 - 09:02 MDT
Investigating
An issue exists with the weblogin at sycnedtool.com and it is currently unavailable. Other Anchor services such as local file sync are functioning as expected. We are looking into the issue now.
Posted Aug 03, 2018 - 08:09 MDT
This incident affected: x360Sync (x360Sync Web (US)).